Vous êtes ici dans : Documentation

Passage à PHP 5.4 chez 1and1 : des problèmes en perspective

Mise à jour décembre 2014

L’annonce d’avril 2013 n’a pas été appliquée à l’époque semble-t-il. Cependant, 1and1 a trouvé une solution : prolonger la durée de vie de la version 5.2 moyennant un léger surcoût (c’est de bonne guerre et c’est un plus pour les sites qui sont incompatibles avec les nouvelles versions).

Pour ceux qui ont des SPIP à jour (3.0.17 et 2.1.26), il y a juste un soucis de time zone facilement contournable : créer un fichier mes_options.php dans le dossier /config et mettre à l’intérieur :

<?php
if (function_exists('date_default_timezone_set'))
       date_default_timezone_set('Europe/Paris');
?>

Pour ceux qui ont du mal à le créer, téléchargez l’archive, décompressez la et enregistrez le fichier mes_options.php dans /config.

Archive : Un véritable poison d’avril 2013 pour un bon nombre de clients 1and1 : PHP 5.4.

1er avril 2013 : l’hébergeur 1and1 modifie la version de PHP en 5.4 pour ses hébergement mutualisés linux.

Le passage de PHP à la version 5.4 par 1and1 a été planifié plusieurs mois à l’avance. Les clients ont été informés par mail en temps utile, leur permettant d’anticiper ce changement. Mais une grande partie des utilisateurs ne va pas prendre la mesure du changement. En effet, pour le néophyte, une version de PHP ne signifie pas grand chose.

Quel sera le résultat du passage à PHP 5.4 ?

  • pour les sites récents ou les sites correctement maintenus : ce changement n’aura aucun impact visible
  • pour les sites basés sur un développement récent mais non maintenus : des dysfonctionnements pourront apparaître sur certaines pages, des messages d’erreur pourront s’afficher
  • pour les sites construits avec du code PHP à l’ancienne, le site pourra être complètement bloqué.

Les version récentes de SPIP 2.1, de SPIP 3 et les blogs sous Wordpress ne poseront a priori pas de problème. Idem pour Dolibarr 3.2.

Pour les sites wordpress avec des thèmes ou plugins anciens non maintenus, pour Prestashop 1.5 et 1.4.9, des dysfonctionnements pourront apparaître.

Pour les anciennes versions de CMS, sites de E-commerce ou CRM, une mise à jour sera indispensable. Cela risque d’être douloureux pour les systèmes suivants :

  • Wordpress si le site comporte de nombreux plugins
  • Prestashop (problèmes avec les thèmes et modules « maison »)

PHPlist : la cata !

Pour le système de gestion de lettre d’information PHPlist : il n’y a pas de solution à ma connaissance. Il faut envisager un changement de serveur comme seule solution court terme.

Édit du 10 avril

Ce n’était pas un poisson d’avril de la part de 1and1, mais pourtant à ce jour les serveurs n’ont toujours pas basculé. Il paraît que ça ne devrait pas tarder...


Si vous avez besoin de conseils : n'hésitez pas à me contacter

 
Bientôt une nouvelle version du site Encore un peu de patience !